Maple 10 is the latest version of the mathematical (symbolic) software Maple. Information about Maple can be found at http://www.maplesoft.com.

**Launching Maple 10**
The location of the Maple 10 icon varies from computer to computer, particularly if using the computer labs on campus. For an individual Maple 10 server, you will find the Maple 10 icon at *Start>* *All Programs>* *Maple 10>* *Maple 10*. This will launch the preferred Maple 10 interface, as shown below.

![Image of Maple 10 interface](image)

*Figure 1. Maple 10 interface when first launched.*

*The Quick Help window*
You will notice an informational window hovering over the interface. This window, labeled *Startup*, provides links for help on Maple, and a random tip on using Maple. Click this screen off, to get to the main Maple interface. In the upper right corner of the main Maple interface you will find a black-background window with a list of help references for using Maple. This *Quick Help* window is reproduced below.

The objective of the *Quick Help* window is to provide a quick reference to the most useful operations and concepts in Maple. If you had clicked off the *Quick Help* window, and would like to recover it, simply press the [ F1 ] key in your keyboard.
You can click on any of the lines in the Quick Help window to obtain a help window with detailed information on that particular operation. For example, for information on functions, click the line *Functions* \( f:x \rightarrow x^2 \) in the Quick Help window. This opens a Maple screen entitled *Maple 10 Help – [worksheet, help, QuickHelpDetails]*, which will show some information on how to define functions in Maple. This is illustrated in Figure 3, below. By scrolling the right-hand side window, notice that this worksheet contains detailed information on all the topics included in the Quick Help window.

*Maple 10 Help directory tree*

Also, notice that the detailed help worksheet contains a directory tree in the left-hand side with folders and documents. These are Maple help documents, and you can access them from this directory tree by double clicking on a document or folder. Notice that the directory tree shows a document entitled *Quick Help – Detailed Information* highlighted. This is the help document that you are currently reading. You can navigate the directory tree on the left hand side of this window to open other relevant help documents. For example, if you were interested in learning about the *Math Dictionary*, you would double click on that document in the directory tree. Thus, we have shown here how to access the Maple Help display through the use of the Quick Help window. Remember, to recover the Quick Help window, simply press [ F1 ]. Alternatively, you can select Help > Quick Help in the Maple 10 menu bar.
Using the Math Dictionary

The Math Dictionary is an alphabetical listing of quick references on mathematical concepts. The Math Dictionary, and other references, are available by selecting Help > Manuals, Dictionary and more... > Dictionary in the main Maple 10 interface. As an exercise, find information about the Laplace Transform by opening the dictionary and finding the listings under the letter L. You should get the information shown in the following figure.

As additional exercises on the use of the Math Dictionary, find the following entries: circle of curvature, heat equation, Napierian logarithm, radian, Ramanujan, factor theorem, Babbage’s engine, Bernoulli equation, beta function, Cartesian product, complex number, Laplace equation, normal distribution, quadratic equation, tesselation, translation, gamma function, and Klein bottle.
Using Maple 10's Help

The Help item in the Maple 10's menu bar allows access to many other Help documents for Maple 10. The items available are shown in the figure below:

Figure 5 – Items in Maple 10's Help menu.
You are welcome to explore all the entries shown. The use of these entries is discussed briefly next:

- Maple Help (Cntl F1): Opens Maple's Help window
- Take a Tour of Maple: Detailed tour of Maple – a good start for new users
- Quick Reference (Cntl F2): Worksheet summarizing basic Maple operation
- Quick Help (F1): Quick Help window (discussed above)
- Help on Context: Help for specific context in a Maple 10 document
- What's New: Highlights new features in Maple 10 version
- Startup Dialog...: Launches Startup window (discussed above)
- Manuals, Dictionary, and more: Maple and math documents (see below)
- Maple on the Web: Links to maplesoft's web sites
- About Maple: Version and other basic information

**Manuals, Dictionary, and more**

The item *Manuals, Dictionary, and more* shows the following items:

- **Help**
  - Maple Help Ctrl+F1
  - Take a Tour of Maple
  - Quick Reference Ctrl+F2
  - Quick Help F1
  - Help on Context F2
  - What's New
  - Startup Dialog...

- **Manuals, Dictionary, and more**
  - New User Roadmap
  - Maple Resources
  - Using the Help System
  - Tasks
  - Applications and Examples
  - Shortcut Keys
  - List of Packages
  - List of Commands

- **Manuals**
  - Dictionary
  - On the Web

Figure 6 – Items in the *Manuals, Dictionary, and more* entry for Maple 10's *Help* menu.

**New User Roadmap**

Out of the items shown in Figure 6 for the *Manuals, Dictionary, and more* entry, the first one is the *New User Roadmap*. This document is a diagram of suggested resources for using Maple 10 relevant to the user's objective. The *New User Roadmap* is shown next.
Learn principles and review major features

Read the Getting Started Guide
From the Help menu, select Manuals, Dictionary, and more. Select Manuals and then Getting Started Guide.

Solve a problem immediately?

Check for point-and-click tools
Assistants
For analyzing ODEs and ODE systems, creating plots, supporting curve fitting, performing unit conversion, and more.
From the Tools menu, select Assistants

Tutors
For topics in precalculus, calculus, multivariate calculus, vector calculus, and linear algebra.
From the Tools menu, select Tutors

Task Templates
Show you the steps required to solve a problem. Each task is a collection of Maple worksheet content, such as 2-D math, embedded components, commands, and plots that you can insert into your worksheet.
From the Tools menu, select Tasks, and then Browse.

Check for instructions
Help Pages
An online help system that you can use to find information about a specific topic, command, package, and feature.
From the Help menu, select Maple Help.

Example Worksheets
Encoded, executable worksheets that demonstrate syntax or invoke Maplet application interfaces making complex problems easy to solve and visualize.
From the Help menu, select Manuals, Dictionary, and more, and then Applications and Examples.

Check for other ready-to-use resources:
Maple Application Center
Maple's Web site resource for free applications related to mathematics, education, science, engineering, computer science, and more.
Go to http://www.maplesoft.com
In the menu of the main Web page, click Resources, and then Application Center.

Figure 6 – New User Roadmap for Maple 10

Getting Started with Maple 10 – Page 6
Maple Resources
This item in the Manuals, Dictionary, and more entry for Maple 10's Help menu opens up a worksheet with additional links to Maple references and resources. It even repeats some of the other items listed under Manuals, Dictionary, and more. The items listed for this entry are:

- Tour and New User Roadmap
- Tutors, Assistants, and Task Templates, and Maple Calculator
- Online Help and Examples
- Palettes and Context Menus
- Manuals
- Web Resources

Click on the corresponding links in the Maple Resources worksheet to open the corresponding references.

Using the Help System
This item in the Manuals, Dictionary, and more entry for Maple 10's Help menu opens up a worksheet with additional links to specific instructions on using Maple's Help facilities. Click the various links to learn more about searching the Help facilities, etc. The following are some of the links available in this worksheet:

Finding Information
To learn about different ways of finding help topics, click the following links.
- Context Help
- Display a Known Help Topic
- Display Tool Tips
- Help Navigator
- Perform a Search
- Search Topic Index
- Review Help History
- Table of Contents

Help Menus and Toolbars
For descriptions of the menus, menu items, and toolbar buttons displayed when viewing Maple help pages, click the following links.
- Overview of Help Menu
- Overview of Help System Menu Bar
- Help Toolbar
- Status Bar

Tasks
This entry describes Maple tasks. Typically, these are worksheets that perform a specific set of operations, and to which one can attach a Help facility entry.
Applications and Examples
This item opens a worksheet with links to examples of Maple applications.

Shortcut keys
This item produces a list of most commonly used shortcut keys. Here is the listing of the shortcuts for the Windows version of Maple 10:

<table>
<thead>
<tr>
<th>Shortcut Keys</th>
<th>Function</th>
</tr>
</thead>
<tbody>
<tr>
<td>Ctrl + Space</td>
<td>Complete Command</td>
</tr>
<tr>
<td>Home</td>
<td>Cursor to Start of Line</td>
</tr>
<tr>
<td>End</td>
<td>Cursor to End of Line</td>
</tr>
<tr>
<td>Ctrl + Home</td>
<td>Cursor to Top of Worksheet</td>
</tr>
<tr>
<td>Ctrl + End</td>
<td>Cursor to Bottom of Worksheet</td>
</tr>
<tr>
<td>Ctrl + Down Arrow</td>
<td>Move to Bottom of Execution Group</td>
</tr>
<tr>
<td>Ctrl + Up Arrow</td>
<td>Move to Top of Execution Group</td>
</tr>
<tr>
<td>Shift + Enter</td>
<td>Soft New Line</td>
</tr>
<tr>
<td>Alt + Shift + F6</td>
<td>Cycle through Open Maple Windows</td>
</tr>
</tbody>
</table>

For a list of math editing shortcut keys, see 2-D Math Shortcut Keys and Hints.

The following is a list of menu accelerators.

<table>
<thead>
<tr>
<th>Shortcut Keys</th>
<th>Function</th>
</tr>
</thead>
<tbody>
<tr>
<td>Alt + F</td>
<td>Open File Menu</td>
</tr>
<tr>
<td>Alt + E</td>
<td>Open Edit Menu</td>
</tr>
<tr>
<td>Alt + V</td>
<td>Open View Menu</td>
</tr>
<tr>
<td>Alt + I</td>
<td>Open Insert Menu</td>
</tr>
<tr>
<td>Alt + R</td>
<td>Open Format Menu</td>
</tr>
<tr>
<td>Alt + T</td>
<td>Open Tools Menu</td>
</tr>
<tr>
<td>Alt + W</td>
<td>Open Window Menu</td>
</tr>
<tr>
<td>Alt + H</td>
<td>Open Help Menu</td>
</tr>
<tr>
<td>Alt + F + D</td>
<td>Send Email with attached worksheet</td>
</tr>
<tr>
<td>Alt + F + M</td>
<td>Recent Documents Menu</td>
</tr>
<tr>
<td>Ctrl + N</td>
<td>New Document/Worksheet (based on Options setting)</td>
</tr>
<tr>
<td>Ctrl + O</td>
<td>Open Worksheet</td>
</tr>
<tr>
<td>Ctrl + F4</td>
<td>Close Current Worksheet</td>
</tr>
<tr>
<td>Ctrl + S</td>
<td>Save Worksheet</td>
</tr>
<tr>
<td>Ctrl + P</td>
<td>Print Worksheet</td>
</tr>
<tr>
<td>Ctrl + Shift + P</td>
<td>Page Setup</td>
</tr>
<tr>
<td>Alt + F4</td>
<td>Exit Maple</td>
</tr>
<tr>
<td>Ctrl + Z</td>
<td>Undo</td>
</tr>
<tr>
<td>Ctrl + Y</td>
<td>Redo</td>
</tr>
<tr>
<td>Ctrl + X</td>
<td>Cut Selection to Clipboard</td>
</tr>
<tr>
<td>Ctrl + C</td>
<td>Copy Selection to Clipboard</td>
</tr>
<tr>
<td>Ctrl + V</td>
<td>Paste Selection from Clipboard</td>
</tr>
</tbody>
</table>

Getting Started with Maple 10 – Page 8
Ctrl + Delete       Delete a line
Ctrl + A            Select All
Ctrl + F            Find/Replace
F5                  Switch between Text and Math mode
F3                  Split Execution Groups
F4                  Join Execution Group
(To split/join with the previous execution group, place the cursor at the start of the Maple input.)
(To split/join with the lower execution group, place the cursor at the end of the Maple input.)
Shift + F3          Split Sections
Shift + F4          Join Sections
Enter               Evaluate Expression
Ctrl + =            Evaluate and Display
Ctrl + 0            Zoom Factor...50%
Ctrl + 1            Zoom Factor...75%
Ctrl + 2            Zoom Factor...100%
Ctrl + 3            Zoom Factor...150%
Ctrl + 4            Zoom Factor...200%
Ctrl + 5            Zoom Factor...300%
Ctrl + 6            Zoom Factor...400%
F9                  Show Region Ranges
Shift + F9          Show Section Ranges
Ctrl + T            Text Input Mode
Ctrl + M            Maple Input Mode
Ctrl + R            2-D Math Mode
Ctrl + L            Label Mode
Ctrl + Enter        Insert Page Break
Ctrl + J            Insert Execution Group After Cursor
Ctrl + K            Insert Execution Group Before Cursor
Shift + Ctrl + J    Insert Paragraph After
Shift + Ctrl + K    Insert Paragraph Before
Ctrl + B            Bold Style Attribute (text or Maple input)
Ctrl + I            Italic Style Attribute (text or Maple input)
Ctrl + U            Underline (text or Maple input)
Ctrl + .            Enclose Section in Subsection (Indent)
Ctrl + ,            Remove Section Enclosing Selection (Outdent)
F7                  Spellcheck
Ctrl + Space        Complete Command
F1                  Quick Help Pop-up Menu
F2                  Context-sensitive Help
Ctrl + F1           Help Table of Contents
Ctrl + F2           Maple Quick Reference Card
List of Packages
This item opens a worksheet with a listing of all Maple 10 function packages. A package is a collection of related functions which can be loaded at once with the command `with`.

List of Commands
This item opens a worksheet with a listing of all Maple 10 top level commands. These are the commands available right away, as soon as Maple is started. Commands in packages need to be called by referring to the package name, or by loading the package first with the command `with`. For example, to produce an implicit plot of an equation in two-dimensions, we can write:

```maple
plots[implicitplot](x^2+y^2-25 = 0, x = -10 .. 10, y = -10 .. 10);
```

or, alternatively,

```maple
with(plots):
implicitplot(x^2+y^2-25 = 0, x = -10 .. 10, y = -10 .. 10);
```

Manuals
This item contains two entries:

- Getting Started Guide
- User's Manual

Select one of these items to open the corresponding manual. These are the official Maple 10 manuals in worksheet format. (These manuals are provided in printed form with each copy of Maple 10).

On the Web
These entries require an Internet connection and provide additional Maple 10 resources on line. Check the different entries for details.
Maple Tour
The Maple Tour is a good way to get initiated with Maple 10. To activate the tour, use Help > Take a Tour of Maple. The resulting worksheet has links to worksheets illustrating the following issues in Maple:

1. Ten Minute Tour
   A quick tour of Maple
2. Numeric and Symbolic Computations
   Basic calculations in Maple
3. Matrix Computations
   Matrix and linear algebra
4. Differential Equations
   Ordinary and partial differential equations
5. Special Functions
   E.g., Bessel, Airy, etc.
6. Optimization
   Finding maxima and minima with constraints
7. Statistics
   Probability and statistical applications
8. Programming and Code Generation
   Program in Maple, translate to C, Java, etc.
9. Dictionary of Math and Engineering
   (discussed earlier)
10. Units and Tolerances
    Using units and quantities with tolerances
11. Education, Assessment, Maple T.A.
    Use Maple for student assessment
12. OpenMaple
    Easy connection to other programs
13. Maplets and MapleNet
    GUIs for Maple, and online deployment

For basic mathematics and engineering applications I suggest you cover at least items 1 through 4 in this list. Item 5 is applicable to advanced problems in differential equations. Item 6 is useful for optimization applications. Item 7 is needed for a course on probability and statistics. Item 8 will be necessary for writing Maple procedures. Item 9 is an excellent reference for most mathematics and engineering applications. Item 10 can be applied to laboratory physical measurements for error analysis. Items 11 is most useful to instructors to develop online-type of assessment activities. Item 12 is for advanced applications linking Maple to C, FORTRAN, or Java programs. Maplets, in Item 13, are graphic user interfaces (GUI) for Maple applications, while MapleNet is a service provided by maplesoft to post Maple applications online.

Creating a new worksheet
To create a new worksheet use File > New > Document mode .. or simply press Cntl+n. This will create an empty worksheet in document mode. In this mode, the cursor at the top of the worksheet is an italic forward slash (/) and the entry mode is Math. The upper left corner of the Maple worksheet will look like this:

![Figure 7 – Cursor and entry mode (Math) for default new worksheet in Maple 10.](image)
Math entry mode
In this entry mode one can type a mathematical expression or a Maple command. An example of a Maple command to try would be:

\[
\text{plot3d}((x-y)*(x+y)-2*x, x = -2 .. 2, y = -2 .. 2, \text{axes} = \text{boxed})
\]

Type it as shown above. However, be aware that in Math input, Maple will change the asterisks (*) into dots (\(\cdot\)), so that the entry line will actually look as:

\[
\text{plot3d}((x - y) \cdot (x + y) - 2 \cdot (x + 2 \cdot y), \ x = -2 .. 2, \ y = -2 .. 2, \ \text{axes} = \text{boxed})
\]

Press [Enter] after typing this command to get a plot of the function used as first argument of function \text{plot3d}. The arguments \(x = -2..2\) and \(y = -2..2\) represent the ranges of values of \(x\) and \(y\), respectively, to be used in the production of the graph. The last argument, \(\text{axes} = \text{boxed}\), indicates that the three-dimensional space where the graphic will be produced will be contained within a coordinate box showing the \(x\), \(y\), and \(z\) axes in the edges. The result is the following graph:

![Graph produced with the plot3d command shown above.](image)

Figure 8 – Graph produced with the \text{plot3d} command shown above.
Math entry can be used to enter simple arithmetic expressions, for example, click below the graph obtained earlier and type:

\[
\sqrt{2 + \frac{3}{5 + \frac{2}{3}}}
\]

Ctrl+Space (click on \textit{sqrt}, the square root symbol)

(right-arrow key, twice \Rightarrow \Rightarrow)

The resulting Maple input is the quantity with the square root in the left-hand side of the screen, while the output is the quantity shown in blue in the middle of the screen. To the right-hand side of the screen Maple generates an automatic label, (1), to identify the output. The section of the Maple screen showing the input, output, and label is shown next:

\[
\frac{1}{17} \sqrt{731}
\]

(1)

\textit{Figure 9} – Example of an arithmetic expression in Math entry form, showing input, output, and label.

Before continuing with more exercises in the Maple worksheet, we'll describe the buttons palette located at the top of the Maple interface.

\textbf{Maple tool bar}

The following figure shows the top of the Maple interface including the \textit{menu bar} and the \textit{tool bar}. While in your computer the menu bar and tool bar occupy the top of the interface, they're shown split in two parts in Figure 10 in order to fit the page width. Also, the 36 buttons in the tool bar have been labeled with numbers (1-36) to identify their function in the description below.

Buttons 1 through 8 correspond to typical operations that apply to almost any software, i.e., \textit{1-new file}, \textit{2-open a file}, \textit{3-save file}, \textit{4-print}, \textit{5-print preview}, \textit{6-cut selection}, \textit{7-copy selection to clipboard}, and \textit{8-paste clipboard contents}. As with many software applications, hovering the cursor over each button will provide an information balloon with the button operation.

\textit{Getting Started with Maple 10} – Page 13
The operation of the remaining buttons in the tool bar is listed next by using the identifying numbers shown in Figure 10:

9 – Undo last operation  
10 – Redo last undone operation  
11 – Insert text  
12 – Insert Maple input  
13 – Enclose selection into a section or subsection (see the Insert menu)  
14 – Remove section or subsection enclosing selection  
15 – Move back to previous worksheet  
16 – Move forward to next worksheet  
17 – Execute entire worksheet  
18 – Execute selection  
19 – Stop execution of current operation  
20 – Debug current operation (useful in programming)  
21 – Restart Maple server (clears Maple memory)  
22 – Zoom to 100%  
23 – Zoom to 150%  
24 – Zoom to 200%  
25 – Toggle entry of tab characters with tab  
26 – Open help system  
27 – Bold characters  
28 – Italics characters  
29 – Underlined characters  
30 – Change font color in characters  
31 – Change background color in selection  
32 – Align to the left  
33 – Center characters  
34 – Align to the right  
35 – Bulleted list  
36 – Numbered list

All of the button operations are available under the different menus, e.g., buttons 9 and 10 (undo, redo) are also available in the Edit menu. So, the tool bar facilitate performing a good number of operations by a single click. Become familiar with all the buttons in the tool bar to use Maple more efficiently.
Maple palettes
Maple offers a number of palettes listed on the left-hand side of the interface as shown in the figure below.

Each palette is opened by clicking on the arrow attached to its name. For example, the Expression palette shows a collection of mathematical operations including integrals, summations, products, derivatives, partial derivatives, limits, powers, sub-indices, square root, $n$-th root, factorials, absolute value, exponential function, natural logarithm, base-10 logarithm, base-$b$ logarithm, trigonometric functions, combinations (binomial coefficient), function references for one or two variables, mapping definition of a function of one or two variables, evaluation of a function at a point, and multiple-valued functions.

Figure 11 – Collection of Maple 10's palettes.
Figure 12 – Components of the Expression palette.

**Typing mathematical expressions in Math entry mode**

The *Expression* palette can be used to build mathematical expressions. For example, click under the last expression in your worksheet and use the summation symbol in the *Expression* palette to create the following summation:

\[
\sum_{r=1}^{\infty} \frac{1}{r^2}
\]

Here are the step-by-step instructions to build this expression:
• Click on the summation symbol in the \textit{Expression} palette (the $i$ in the lower side of the symbol will be highlighted)
• Type $r$
• Press the \textit{tab} key in your keyboard (moves cursor from one entry point to the next)
• Type 1
• Press \textit{tab}
• Click on the infinity symbol ($\infty$) from the \textit{Common Symbols} palette (the $f$ will be highlighted now)
• Type $1 / r^2$

At this point, the expression is complete. We can do a couple of things with it: (1) highlight it, and use \textit{Edit > Copy} (or \textit{Cntl+C}) to copy it to the clipboard and, then, paste it into, say, a \textit{Word} file (in this case we would have used Maple as an equation editor); or, (2) press [Enter] to calculate the expression. Press [Enter] to calculate the expression. The result should be as follows:

$$\sum_{r = 1}^{\infty} \frac{1}{r^2} = \frac{1}{6} \pi^2$$

\textit{Figure 13} - Example of algebraic operation in \textit{Math} entry mode in Maple 10.

Notice that, as in the case of the arithmetic expression used earlier, we have an input (left-hand side), and output (center), and an automatic label (right-hand side).

\textbf{Context menus}

\textit{Context menus} are menus that are available to operate on Maple inputs and/or outputs. The items in the context menus are selected automatically by Maple and contain only operations that are relevant to the expression selected. These menus are activated by clicking on the input or output expression (sometimes, the whole expression must be highlighted) and then doing a \textit{right-click} with the computer mouse.

As an example, go back to the input algebraic expression used earlier (the one with the square root), and click somewhere inside it. Then, do a \textit{right-click} with the mouse. The context menu that you get will look like the following figure. Among the operations available, we could try, for example the option \textit{Approximate}. This operation produces a floating-point result for the symbolic operation under the square root. Clicking on the \textit{Approximate} item produces a sub-menu with the options 5, 10, 20, 50, 100. These numbers indicate the number of digits in the approximate (floating-point result).
Figure 14 – Context menu for an arithmetic operation.

For the case under consideration, using 10 digits, for example, will produce the result:

\[ \sqrt{2 + \frac{3}{5} + \frac{2}{3}} \rightarrow 1.590412451 \]

Notice that the use of the context menu produced an arrow (indicating an operation was performed) followed by the floating-point result. Thus, context menu items do not document their operation very well in a Maple worksheet. Added comments by the user can help interpret the results for any potential reader of their worksheets if context menus are used. The use of text to document Maple 10's worksheets is shown later. Next, we'll try using the Approximate context-menu item but selecting the output of the square-root operation rather than the input.

Getting Started with Maple 10 – Page 18
Going back to your worksheet, click on the output for the square-root operation, namely, on the term

\[
\frac{1}{17} \sqrt{731}
\]

Then, use the context menu \(\text{(right-click)}\) to calculate an approximation with 20 digits:

\[
\sqrt{\left(2 + \frac{3}{5 + \frac{2}{3}}\right)} \rightarrow 1.590412451
\]

\[
\frac{1}{17} \sqrt{731}
\]

\[\text{(1)}\]

![Figure 15 – Using context menu to approximate a symbolic result using the output of a Maple operation.](image)

The results is shown next:

\[
\sqrt{\left(2 + \frac{3}{5 + \frac{2}{3}}\right)} \rightarrow 1.590412451
\]

\[
\frac{1}{17} \sqrt{731}
\]

\[\rightarrow 1.5904124511289146572\]

\[\text{(1)}\]

Notice that the arrow indicating the operation is shown now below the output. Obviously, for documentation purposes, we need to add some text to the worksheet.

**Adding text to a worksheet**

To add text to a worksheet, click in the location where you want to add the text, then, press \([\text{F5}]\) to toggle the input format from \(\text{Math}\) to \(\text{Text}\). Type the desired text in that location. Select another location to insert more text, then repeat the steps indicated.
above. For example, by inserting text around the previous calculation we can re-write this piece of the worksheet as follows: (Note: The text input cursor is a vertical line. When a text input is requested, the left part of the toolbar will show the Text box highlighted. Also, we used backspace to remove the arrows from the worksheet).

The square root \(\sqrt{\frac{2 + \frac{3}{5} + \frac{2}{3}}{3}}\) is approximated by 1.590412451, using 10 digits.

The output of the square root, shown as expression (1), below, is

\[
\frac{1}{17} \sqrt{731}
\]

and this value is approximated as 1.5904124511289146572, using 20 digits.

\[x^2 + 3x^2 + 25\]

Type \(x^2 + 3x + 25\). Then, before pressing [Enter], do a right-click to obtain the corresponding context menu. From this context menu, we'll try the following applications:

- Evaluate at a point - This option generates the following dialog box:

\[\text{Figure 16 – Arithmetic calculation edited by inserting text in a Maple worksheet (frame added for emphasis, it cannot be produced in Maple).}\]

\[\text{Context menus for algebraic expressions}\]

Try some context menu operations with algebraic expressions.

\[\text{Example 1}\]

Click in a location of your worksheet below the last operation listed there, and type the expression (Note: Use [F5] to toggle to Math input if a text cursor shows up):

\[x^2 + 3x^2 + 25\]

Type \(x^2 + 3x + 25\). Then, before pressing [Enter], do a right-click to obtain the corresponding context menu. From this context menu, we'll try the following applications:

- Evaluate at a point - This option generates the following dialog box:

\[\text{Figure 17 – Dialog box for context-menu Evaluate at a Point operation.}\]
Replace the value of $x$ with 2.5, and press [OK] to get:

$$x^2 + 3x + 25 \rightarrow 38.75$$

- **Differentiate**
  Next, highlight the original expression, namely, $x^2 + 3x + 25$, and, do a copy (Cntl-C). Click on a location below the current one, and do a paste (Cntl-V), to make an extra copy of the original expression. Then, using a context menu (right-click), select the option **differentiate > x**, to produce:

$$x^2 + 3x + 25 \rightarrow 2x + 3$$

**Control-drag**
Highlight the original expression, namely, $x^2 + 3x + 25$, cut it and paste it below the last result in your worksheet. This time, do press [Enter] to produce a Maple output. Next, highlight the output, and, pressing [Cntl], drag the cursor to a new location below to its original location in the worksheet. After a couple of seconds, a copy of the output will appear as Maple input at the location where you released the mouse button.

- **Integrate**
  Next, using a context menu (right-click), select the option **integrate > x**, to produce:

$$x^2 + 3x + 25 \rightarrow \frac{1}{3}x^3 + \frac{3}{2}x^2 + 25x$$

**Exercise 1**
Using procedures similar to those detailed above for the context-menu operations **Evaluate at a point**, **differentiate**, and **integrate**, and for the same polynomial shown above, try the following context-menu operations:

1. Complete square
2. Solve (solve the equation formed by the expression = 0)
3. Coefficients > x
4. Constructions > Definite Integral > x (Lower Limit = 0, Upper Limit = 1)
5. Constructions > Derivative > x
6. Constructions > Evaluate at > x (at 1)
7. Constructions > Limit > x (at 0)
8. Constructions > Product > x (Lower Limit = 1, Upper Limit = 10)
9. Constructions > Sum > x (Lower Limit = 1, Upper Limit = 10)
10. Conversions > Horner Form > x
11. Conversions > To String
12. Integral Transforms > Fourier Transforms
Exercise 2
Enter the following rational fraction as Maple input:

\[ \frac{x^3 - x^2 - x + 10}{x^2 - 4} \]

Using context menus, try the following operations in Maple 10:

1. Evaluate at a point
2. Factor
3. Normal
4. Solve (solve the equation formed by the expression = 0)
5. Numerator
6. Denominator
7. Constructions > Definite Integral > x (Lower Limit = 0, Upper Limit = 1)
8. Constructions > Derivative > x
9. Constructions > Evaluate at > x (at 1)
10. Constructions > Limit > x (at 0)
11. Constructions > Product > x (Lower Limit = 1, Upper Limit = 10)
12. Constructions > Sum > x (Lower Limit = 1, Upper Limit = 10)
13. Conversions > Partial fractions > x
14. Conversions > To String
15. Integral Transforms > Fourier Transforms

Exercise 3
Enter the following trigonometric polynomial as Maple input:

\[ \sin(x) + \cos(2 \cdot x) + \sin^2(x) \]

Using context menus, try the following operations in Maple 10:

1. Evaluate at a point
2. Factor
3. Solve numerically (solve the equation formed by the expression = 0)
4. Constructions > Definite Integral > x (Lower Limit = 0, Upper Limit = 1)
5. Constructions > Derivative > x
6. Constructions > Evaluate at > x (at 1)
7. Constructions > Limit > x (at 0)
8. Constructions > Product > x (Lower Limit = 1, Upper Limit = 10)
9. Constructions > Sum > x (Lower Limit = 1, Upper Limit = 10)
Title, sections and sub-sections
When preparing a well-documented worksheet, we may want to give the worksheet a title, and introduce sections and sub-sections into the worksheet. These items would allows us to organize subjects in a reasonable fashion. For example, if we're writing a worksheet about polynomials and fractions, we could type a title Polynomials and Fractions, and, then, insert a section called Polynomials and one called Fractions.

To do this exercise, create a new worksheet. Then, to enter a title, click at the top of the worksheet. Use [ F5 ] to ensure you're in text mode, and select P Title from the input/output descriptor located in the toolbar. Type the title. For this example, the top of the worksheet may look as follows:

![Figure 18 – Typing a title in a worksheet.](image)

To insert sections use Insert>Section (or use the insert section button – i.e., button number 13 in Figure 10). The cursor will remain at the location of the section's title. Type Polynomials. Then, press return, press [ F5 ] to toggle between Math and Text format, and type a few lines in your worksheet describing the section and introducing a polynomial ($x^3 + 2x^2 - 5x + 3$) that will be used in the operations illustrated in the section. Then, we'll insert a couple of sub-sections (Evaluate at a point and Integrate), by using the insert section button. Copy the polynomial into them and evaluate the polynomial at $x = 2$, and integrate with respect to $x$. Document the operations.

Go back to the upper level of sections in the worksheet and insert a section to be called Fractions below the Polynomials section. Insert a few lines introducing the section, and define the fraction

$$\frac{x^3 - x^2 - x + 10}{x^2 - 4}$$

to be used in the sub-sections defined next. Within this section insert sub-sections entitled Normal fractions and Numerator & Denominator. Perform such calculations using context-menus and document the sessions with text.

You can insert as much documentation into your worksheet's sections and subsections as you wish in this exercise. One possible outcome of this exercise is shown in the following page.
Polynomials and Fractions

\textbf{Polynomials}

This is a simple polynomial:
\[ x^3 + 2x^2 - 5x + 3 \]
upon which we perform the following operations:

\textbf{Evaluate at a point}

We use a context menu to evaluate this polynomial at \( x = 2 \)

\[ x^3 + 2x^2 - 5x + 3 \rightarrow 9 \]

\textbf{Integrate}

We use context menu again to calculate the indefinite integral of the polynomial

\[ x^3 + 2x^2 - 5x + 3 \rightarrow \frac{1}{4}x^4 + \frac{2}{3}x^3 - \frac{5}{2}x^2 + 3x \]

\textbf{Fractions}

Use the fraction \( \frac{x^3 - x^2 - x + 10}{x^2 - 4} \) in the following sub-sections:

\textbf{Normal fraction}

Using the \textit{Normal} operation from the context menu

\[ \frac{x^3 - x^2 - x + 10}{x^2 - 4} \rightarrow \frac{x^2 - 3x + 5}{x - 2} \]

\textbf{Numerator}

Using functions \textit{Numerator} in the context menu

\[ \frac{x^3 - x^2 - x + 10}{x^2 - 4} \rightarrow x^3 - x^2 - x + 10 \]

\textit{Figure 19} – Example of a worksheet with a title, sections, and sub-sections.

Note: Click on the arrow defining each section of sub-section to open or close that section or sub-section. Use \textit{View>Expand All Sections} or \textit{View>Collapse All Sections} to manipulate all sections and sub-sections at once.
Using Tables
A table can be inserted in a Maple worksheet to organize data or to organize examples in the worksheet. Let's try an exercise using tables. Open a new worksheet (Cntl + n), and type the title *Examples of ordinary differential equations*, and press enter. To insert the table, use *Insert > Table* to produce the following dialog.

![Image of Insert Table dialog box]

Select the default values, namely, 3 rows, 2 columns, and press OK. As a result, you will get a blank table with 3 rows and 2 columns. In the first row and first column cell type the following text: *Example 1 – First order, linear, homogeneous*. In the first row, second column enter the differential equation:

\[ x'(t) + x(t) = 0. \]

Click on the equation and generate a context menu (*right-shift click*), and select the item *Solve DE > x(t)* to obtain a symbolic solution for the equation.

In the second row, first column type the text: *Example 2 – Second order, linear, homogeneous*. In the second row, second column enter the differential equation

\[ y''(t) + y'(t) + y(t) = 0 \]

[Note: the double prime in this equation, \( y''(t) \), is typed as two apostrophes and not as a double-quote]. Click on the equation and use the context menu (*right-shift click*) to solve this second equation.

Finally, in the third row and first column, type the text: *Example 3 – Second order, linear, non-homogeneous*. In the third row, second column type the equation:

\[ s''(x) + s(x) = \sin(x), \]

which you will solve using the context menu. When done, the spreadsheet should look somewhat like Figure 21.

*Getting Started with Maple 10 – Page 25*
Examples of ordinary differential equations

| Example 1 - First order, linear, homogeneous | $x'(t) + x(t) = 0 \rightarrow x(t) = _C1 \ e^{(-t)}$ |
| Example 2 - Second order, linear, homogeneous | $y''(t) + y'(t) + y(t) = 0 \rightarrow$
$y(t) = _C1 \ e^{\left(-\frac{1}{2} t\right)} \ \sin\left(\frac{1}{2} \sqrt{3} \ t\right)$
$+ \ _C2 \ e^{\left(-\frac{1}{2} t\right)} \ \cos\left(\frac{1}{2} \sqrt{3} \ t\right)$ |
| Example 3 - Second order, linear, non-homogeneous | $s''(x) + s(x) = \sin(x) \rightarrow$
$s(x) = \sin(x) \ _C2$
$+ \ \cos(x) \ _C1 - \frac{1}{2} \ \cos(x) \ x$ |

*Figure 21* – Example of a table in a Maple worksheet.

**Using Common Symbols and Greek letters**

Two of the most useful Maple palettes, besides the *Expression* palette, are the *Common Symbols* and *Greek* palettes. The contents of these two palettes are shown below.

*Figure 22* – The Common Symbols and Greek Maple 10 palettes.

*Getting Started with Maple 10* – Page 26
The *Common Symbols* palette includes such commonly used symbols such as:

- **π**  
  The ratio of the length of a circle to its diameter

- **e**  
  The basis for the natural logarithms

- **i, j, k**  
  Unit imaginary numbers \((i^2 = j^2 = -1)\)

- **∞**  
  Infinity

It also includes the common mathematical symbols:

- **Σ**  
  Summation

- **Π**  
  Product

- **∫**  
  Integral

- **∪**  
  Union of sets

- **∩**  
  Intersection of sets

You will also find in this palette comparison symbols (e.g., \(>\), \(<\), etc.), symbols used in set theory (e.g., \(\in, \notin, \subseteq, \emptyset\)), symbols for mathematical logic (\(∃, ∀, ¬, ∧, ∨, ⇒\)), symbols for number sets (\(C, R, N, Q, Z\)), real and imaginary functions for complex numbers (\(ℜ, ℑ\)), arithmetic operations (+, -, ×, /), plus/minus signs (±), degrees (°), asterisk for products (*), dot product (\(\cdot\)), regular product (\(\cdot\)), the *del* or *nabla* operator for vector analysis (\(∇\)), factorial (!), aleph (\(ℵ\)), Planck's constant for quantum mechanics (\(\hbar\)), etc.

These symbols can be very useful for editing equations for inclusion in texts or as input for Maple operations. As an example of equation editing using Maple, here are a couple of examples from vector analysis built using the *del* or *nabla* operator and the partial derivative symbol from the *Expression* palette:

\[
∇f = \frac{∂f}{∂x} i + \frac{∂f}{∂y} j + \frac{∂f}{∂z} k
\]

\[
∇· \mathbf{F} = \frac{∂F_x}{∂x} + \frac{∂F_y}{∂y} + \frac{∂F_z}{∂z}
\]

Union and intersection of sets can be calculated using Maple as follows:

\[
\{1, 3, 5, 7, 9\} \cup \{5, 7, 9, 11\} = \{1, 3, 5, 7, 9, 11\}
\]

\[
\{1, 3, 5, 7, 9\} \cap \{5, 7, 9, 11\} = \{5, 7, 9\}
\]
The *Common Symbols* palette is useful when inserting the base of the natural logarithms (e), which is a different symbol than the letter e. This difference is illustrated by the use of the *Approximate > 5* operation in the context menus of the following two entries:

\[ e^2 + 5 \rightarrow e^2 + 5. \]

\[ e^2 + 5 \rightarrow 12.389 \]

In the first entry we typed the letter e, therefore, the *Approximate > 5* operation does not produce a floating point result (e is assumed to be an unassigned variable). In the second entry, the symbol e was inserted from the *Common Symbols* palette, producing the correct result when *Approximate > 5* was used.

The *Greek* palette contains the letters of the Greek alphabet, which are commonly used in mathematical expressions. The Greek alphabet is listed in the following table.

**Table 1 – The Greek Alphabet**

<table>
<thead>
<tr>
<th>Lower case</th>
<th>Upper case</th>
<th>Letter name</th>
<th>English equivalent</th>
<th>Lower case</th>
<th>Upper case</th>
<th>Letter name</th>
<th>English equivalent</th>
</tr>
</thead>
<tbody>
<tr>
<td>α</td>
<td>A</td>
<td>Alpha</td>
<td>a</td>
<td>ν</td>
<td>Ν</td>
<td>Nu</td>
<td>n</td>
</tr>
<tr>
<td>β</td>
<td>B</td>
<td>Beta</td>
<td>b</td>
<td>ξ</td>
<td>Ξ</td>
<td>Xi</td>
<td>x</td>
</tr>
<tr>
<td>γ</td>
<td>Γ</td>
<td>Gamma</td>
<td>g</td>
<td>Ω</td>
<td>Ω</td>
<td>Omicron</td>
<td>o</td>
</tr>
<tr>
<td>δ</td>
<td>Δ</td>
<td>Delta</td>
<td>d</td>
<td>π</td>
<td>Π</td>
<td>Pi</td>
<td>p</td>
</tr>
<tr>
<td>ε</td>
<td>E</td>
<td>Epsilon</td>
<td>ε</td>
<td>ρ</td>
<td>Ρ</td>
<td>Rho</td>
<td>r</td>
</tr>
<tr>
<td>ζ</td>
<td>Z</td>
<td>Zeta</td>
<td>ζ</td>
<td>σ</td>
<td>Σ</td>
<td>Sigma</td>
<td>s</td>
</tr>
<tr>
<td>η</td>
<td>H</td>
<td>Eta</td>
<td>η</td>
<td>τ</td>
<td>Τ</td>
<td>Tau</td>
<td>t</td>
</tr>
<tr>
<td>θ</td>
<td>Θ</td>
<td>Theta</td>
<td>θ</td>
<td>υ</td>
<td>Υ</td>
<td>Upsilon</td>
<td>u</td>
</tr>
<tr>
<td>ι</td>
<td>I</td>
<td>Iota</td>
<td>i</td>
<td>ϕ</td>
<td>Φ</td>
<td>Phi</td>
<td>ph</td>
</tr>
<tr>
<td>κ</td>
<td>K</td>
<td>Kappa</td>
<td>ς</td>
<td>χ</td>
<td>Χ</td>
<td>Chi</td>
<td>χ</td>
</tr>
<tr>
<td>λ</td>
<td>Λ</td>
<td>Lambda</td>
<td>l</td>
<td>ψ</td>
<td>Ψ</td>
<td>Psi</td>
<td>ψ</td>
</tr>
<tr>
<td>μ</td>
<td>M</td>
<td>Mu</td>
<td>m</td>
<td>Ω</td>
<td>Ω</td>
<td>Omega</td>
<td>o</td>
</tr>
</tbody>
</table>

The *Expression, Common Symbols, and Greek* palettes can be used to produce mathematical expressions for equation editing or as Maple entries, such as:

\[
\mathbf{w} = \sum_{k=1}^{n} \int_{0}^{\tau} (\xi + k \cdot \alpha \cdot \tau) \, d\tau
\]

\[
\mathbf{w} = \xi \tau (n + 1) + \frac{1}{4} \alpha \tau^2 (n + 1)^2 - \frac{1}{4} (n + 1) \alpha \tau^2 - \xi \tau
\] (3)
Using sub-indices

To type sub-indices in mathematical expressions in Maple simply use Shift _ before typing the sub-index. It is necessary to press the right-arrow key to return to the main entry level in an expression. Sub-indices are used in both the numerator and denominator of the following expression:

$$\Omega = \frac{A_o \sin(\omega t)}{\sqrt{(\omega - \omega_1)^2 + (\omega - \omega_2)^2}}$$

$$\Omega = \frac{A_o \sin(\omega t)}{\sqrt{2 \omega^2 - 2 \omega \omega_1 + \omega_1^2 - 2 \omega \omega_2 + \omega_2^2}}$$  \(4\)

Symbol recognition

The Symbol Recognition palette presents a sophisticated symbol recognition device that allows the user to sketch a mathematical symbol or a letter and provides the closest Maple characters that resemble the user's input. The user then can select the intended character to use in Maple. When you click on the Symbol Recognition you get the following form.

Figure 23 – Maple 10's Symbol Recognition form

The numbers shown in Figure 23 do not appear in the Symbol Recognition form and were added to identify the following components:

1. Sketch area: this is where the user sketches the intended symbol
2. Erase button: clears the sketch area
3. Apply button: press this button to allow Maple to recognize the symbol sketched
4. Output area: the area where Maple shows the possible symbols based on the sketch
If the symbol intended by the user is shown in the *output area*, the user can just click on the symbol to copy it into the Maple entry area. If the intended symbol is not included in the output area then the user can repeat the recognition attempt by pressing the *erase button* and sketching the symbol in the *sketch area* once more.

For example, the *approximate* symbol can be sketched as follows:

![Symbol Recognition](image)

*Figure 24 – An exercise in symbol recognition*

Notice, however, that Maple suggested the symbols \( \tau \), \( \theta \), and \( \omega \) as the first three choices in the symbol recognition operation. To obtain the *approximate* symbol it was necessary to look under the *More...* list as shown above. Clicking in the symbol copies it to the Maple entry location.

Other examples of symbol recognition are shown in the following page. In these examples I was trying to obtain the symbols \( \alpha \) (alpha), \( \gamma \) (gamma), and the *del or nabla* operator symbol. Maple was successful in recognizing the intended character in each instance.
Two-dimensional plotting with context menus

An expression (in either input or output in Maple) containing a single independent variable can be used to produce a plot in two dimensions through the use of context menus. For example, to plot the function \( x = 2.5 e^{-t/10} \cos(t/2 + 5) \), in the interval \( 0 < t < 20 \), we need only type the expression \( 2.5 e^{-t/10} \cos(t/2 + 5) \) and select the Plots > 2-D Plot item in the corresponding context menu.

By default, the \( t \) range is \([-10, 10]\). By right-clicking on the plot itself you can generate a context menu for the plot where the \( t \) range can be changed. The item to use in the context menu is Axes > Range, as shown in Figure 26. This selection produces the dialog box shown in Figure 27. To adjust the \( x \) range, we select 0 to 20. The vertical range can be adjusted by selecting the range -2.5 to 2.5. The final version of the graph is shown in Figure 28.
Figure 26 – Context menu for a two dimensional plot.
Figure 27 – *Axes Ranges* dialog box to adjust ranges in a two-dimensional plot.
Two-dimensional plot manipulation
Having generated a two-dimensional plot through a context menu, we will now show how to manipulate such plot using the corresponding toolbar in the main Maple 10 window. First, one needs to click on the plot. This will produce a new row in the toolbar, as shown next.

Figure 29 – Graphics toolbar for a two-dimensional plot
In order to describe the different components of the graphics toolbar we assign numbers to the different fields and menus and letters to the items in the drop-down menus. The description of the numbered components is as follows:

1. Coordinates of cursor on graph
2. Plot style
   (a) Line
   (b) Symbols (points)
   (c) Patch and grid (applies mainly to three-dimensional surfaces)
   (d) Patch but no grid (applies mainly to three-dimensional surfaces)
3. Axes style
   (a) Boxed
   (b) Framed
   (c) Normal axes
   (d) No axes
4. Constrained scale button (1:1 scale when active)
5. Plot manipulator
   (a) Point probe (determines coordinates of cursor location on graph)
   (b) Scale (zooms in and out)
   (c) Pan (moves graph about the plot frame)
6. Grid button (shows grid on plot area when active)

Click on the different menus or buttons and select different properties of the graph. For example, by selecting options 2(a), 3(a), and activating the 1:1 scale button, the graph of Figure 28 is now as shown in Figure 30. Figure 31 shows the same graph with a grid.

![Figure 30](image)

*Figure 30 – Same as Figure 28 but using boxed axes and 1:1 scaling.*

![Figure 31](image)

*Figure 31 – Same as Figure 30 but activating the grid*
Two-dimensional animation with context menus

A Maple animation can be produced on a function of the form \( y = f(x,a) \) where the graph to be animated is \( y = f(x) \) and the animation parameter is \( a \). For example, to produce an animation of the equation \( y = a + \sin(ax) \), we need just type the expression \( a + \sin(ax) \) and do a right-click on the expression to activate a context menu. Then, we select the item \( PLOTS > PLOT \; BUILDER \) from the context menu, and select the \( Animation \) option in the box entitled \( SELECT \; PLOT \; TYPE \). We keep the selection \( 2-D \; PLOT \) in the box entitled \( SELECT \; PLOT \; AS \) well as the ranges \(-10 \) to \( 10 \) for the \( x \) axis, and \( 0 \) to \( 10 \) for \( Animation \; Parameter \; a \) in the box entitled \( SELECT \; VARIABLE \; PURPOSE \; AND \; RANGES \). Then, we press \( [PLOT] \). As a result we obtain a plot that shows no curves on it (this is so because the value \( a = 0 \) produces no plot). In order to see the animation we need to click on the plot and check out the new animation toolbar.

![Maple 10's animation toolbar](image)

Figure 32 – Maple 10's animation toolbar

Figure 32 shows the Maple 10's animation toolbar, split in two parts to fit in the page. The items numbered in Figure 32 are described next:

1. Moves animation backward by one frame
2. Stops animation
3. Plays animation
4. Moves animation forward by one frame
5. Shows framed currently being shown in the graph area
6. Slider that shows the progress of the animation
7. Menu to select animation direction: backward, oscillating, and forward (default)
8. Menu to select animation type: single realization or continuous (repeated) animation
9. Shows the number of frames per second (FPS)
10. Slider to adjust the FPS value
11. Plot manipulator menu (same as discussed in Figure 29)

The reader is invited to run the animation using the different buttons and menus shown.
Three-dimensional surface plotting with context menus
A function of the form \( z = f(x, y) \) can be plotted as a surface in space. Consider the expression \( x^2 \sin(x) + y^2 \cos(y) \). Type this expression in a Maple worksheet, click on the expression and do a right-click to generate a context menu. Select the item Plots>3-D Plots>x,y to see the following plot of a surface in three dimensions.

\[
\begin{align*}
\text{Figure 33} & \quad \text{– Three-dimensional surface representing the function } x^2 \sin(x) + y^2 \cos(y). \\
\end{align*}
\]

When one clicks on the graph itself a new graphics toolbar is produced in the Maple interface as shown in the figure below. This toolbar include the following items:

1. Angle \( \theta \) on \( x-y \) plane, measured from the positive \( x \) axis to plane of point of view
2. Angle \( \phi \) measured from \( z \) axis on the line connecting the origin to the point of view
3. Surface style: (a) patch no grid; (b) patch and grid; (c) patch and contours; (d) contour lines only; (e) grid with hidden surfaces; (f) grid with no hidden surfaces; (g) points
4. Axes style: (a) boxed; (b) framed; (c) normal axes; (d) no axes
5. Axes scaling: 1:1 scaling if active
6. Plot manipulator: same as in two-dimensional plots (see Figure 29).
By default, the plot manipulator is set to rotate (as shown above). To rotate the plot simply click on it, press the left mouse button, and drag in any direction. You will see the plot rotating in space. You will also notice that the values of the angles $\vartheta$ and $\varphi$ change as the graph rotates since, for all practical purposes, we're changing the location of the point of view (i.e., that point in space from which the surface plot is being observed.

Many of the options available through the toolbar are also available through the context menu for the graph. Figure 35 shows some of the options available, in particularly the lightning scheme. Some of the options shown in Figure 35 are described next:

- **Style:** same as item 3 in Figure 34
- **Color:** changes the color(s) of the surface – see Figure 36 for a list of options
- **Lighting:** changes illumination patterns on surface – see Figure 35 for a list
- **Axes:** same as item 4 in Figure 34
- **Scaling ..:** same as button 5 in Figure 34
- **Projection:** scale plot manipulator – same as option 5(b) in Figure 29
- **Transparency:** slider to select surface transparency (0 -- opaque to 1– transparent)
- **Manipulator:** same as item 6 in Figure 34 or item 5 in Figure 29
- **Export:** options for saving a Maple plot as a variety of graphics format files

The reader is invited to manipulate the different options available for three-dimensional surface plots in the context menu or in the toolbar.
Figure 35 – Context menu for a three-dimensional surface plot, Lighting sub-menu highlighted.
Two-dimensional implicit plots with context menus

A function of the form \( f(x,y) = 0 \) or of the form \( g(x,y) = c \) can be used to generate an implicit plot in the \( x-y \) plane through context menus. Consider, the equation

\[
\frac{x^2}{9} + \frac{y^2}{16} = 1
\]

Type this equation in a Maple worksheet in Math entry mode. Click on the equation and generate a context menu for the same (right-click), then select the item Plots > 2-D Implicit Plot.

The result is a plot that looks like a circle. In order to see the true shape of the implicit plot we need to use a 1:1 scaling, which we can get by simply clicking on the plot area and using the [1:1] button in the toolbar. The resulting graph is an ellipse with semi-axes 3 in \( x \) and 4 in \( y \), as shown next.
Implicit plots can also be generated out of an expression of the form $f(x,y)$. In such case, Maple will assume that the corresponding equation to be plotted is $f(x,y) = 0$. For example, using the expression $x^2 \sin(x) + y^2 \cos(y)$, which generated the surface plot of Figure 33, try to generate a two-dimensional implicit plot using a context menu. Select the option *Plots > 2-D Implicit plot > x,y*.

**Drag-and-drop plotting**

Once you have produced a plot (e.g., the ellipse of Figure 37), you can drag an expression or equation from a Maple output and drop it on top of the plot. Maple will automatically generate a new plot atop the existing one corresponding to the expression or equation dropped on the existing plot. For example, repeat the exercise leading to Figure 37. Then, type the equation

$$\frac{x^2}{4} - \frac{y^2}{9} = 1$$

and press [Enter].
The corresponding Maple worksheet, with the output highlighted, will look as follows:

\[ \frac{x^2}{4} - \frac{y^2}{9} = 1 \]

Next, click on the highlighted output and drag it on top of the plot area for the ellipse of Figure 37 in your Maple worksheet. As a result Maple will add the implicit plot for the equation you just dropped on the plot area.

**Legends in graphics**
As an additional exercise, click on the plot and do a right-click to generate the corresponding context menu. Then, select the option *Legend > Edit Legend* to generate a dialog box corresponding to the legends (description) of each of the plots shown in the plot area. For “Legend for Curve 1” type “Ellipse” in the Label field of the dialog box (see Figure 39, below), then press [Done]. As a result, legends will be shown at the bottom of the plot in your Maple worksheet with the legend for the first curve being labeled “Ellipse” while that for the second curve the legend shows the label “Curve 2”.

![Figure 38 – Dialog boxes for editing curve legends in a plot.](image)

To edit the legend for the second curve, once more open the context menu for the plot and select the option *Legend > Edit Legend*. Select “Legend for Curve 2” in the “Curve” field, and type “Hyperbola” for the “Label” field in the dialog box. Then press [Done]. The result from these operations will be the plot as shown in Figure 39.
Figure 39 – Ellipse of Figure 37 with hyperbola added by a drag-and-drop operation. Plot includes legend edited through context menus.

Exercise
Using the expression

$$2.5 e^{0.01t \sin(t)}$$

to generate a 2-D plot in the range \(-10 < t < 10\) (similar procedure to that leading to Figure 28, except that default range for \(x\) is not modified in the present exercise). Use drag-and-drop to add the graphics corresponding to the expressions

$$\sin(t) + \cos(t)$$

and

$$\sin(t) \cos(t).$$

Use the plot's context menu to edit the legends so that the legends for the three expressions read “Damped Sine”, “Sine plus Cosine”, and “Sine times Cosine”, respectively. The resulting graph should look like that in Figure 40.
Figure 40 – Multiple-curve graph generated with a context menu for a damped-sine expression and modified by drag-and-drop operations for sine-cosine addition and multiplication. Plot context menu was used to edit and add legends to the plot.

Plots with logarithmic scales using context menus
Consider the expression

\[ e^{2x} + e^x \]

Using context menu we can generate a 2-D plot showing the variation of the function, \( y = e^{2x} + e^x \). The vertical scale in the default range \(-10 < x < 10\) reaches from 1 to about \(5 \times 10^8\). Using a logarithmic scale for \( y \) would be use to better understand the variation of the function with \( x \). In order to replace the natural scale for a logarithmic one in a graph, we first generate the graph following a procedure similar to that leading to the plot of Figure 28, namely,

- Type the expression \( e^{2x} + e^x \) in Math input format
- Click on the expression and generate a context menu (right-click)
- Select option Plots>2-D plot
The resulting plot will be shown in your Maple worksheet. In order to replace the $y$ scale
with a logarithmic one proceed as follows:

- Click on the plot to select it
- Generate the context menu by doing a right-click
- Select the option *Axes > Mode*

This will produce a dialog box. Modify it so it looks as in Figure 41, below, then press
[Apply][OK], or simply [OK], to produce a logarithmic scale in $y$. The resulting graph is
shown in Figure 42, below.

![Figure 40](image)

*Figure 40 – Dialog box for axes modes generated using a 2-D plot context menu,
and selecting *Axes > Mode*.*

Using the *Axes > Mode* option in a 2-D plot context menu thus allows us to select
logarithmic scales for the $x$ axis only (semilogarithmic plot in $x$), for the $y$ axis only
(semilogarithmic plot in $y$), or for both axes (*double-logarithmic* or *log-log* plot).

**Exercise**
Using the context menu for the plot of Figure 41, try the following:

1. Change the horizontal scale from 1 to 10000
2. Produce a semilogarithmic plot in $x$ ($x$ scale logarithmic, $y$ scale natural)
3. Produce a semilogarithmic plot in $y$ ($x$ scale natural, $y$ scale logarithmic)
4. Produce a double logarithmic plot (both scales logarithmic)
5. Add the plots for the functions $xe^{2x}$ and $e^x$ to the existing plot by a drag-and-drop
   procedure
6. Edit the legends of the resulting plot to read “Exp Sum”, “X time Exp”, and “Exp”
7. Produce the plots indicated in steps 2 and 3, above
Contour plots and density plots using context menus

An expression of the form \( f(x,y) \) can be plotted in a two-dimensional format as a contour plot or as a density plot. In a contour plot curves corresponding to constant values of \( f \), i.e., \( f(x,y) = c \), are shown in the \( x-y \) plane. In a density plot, instead of showing curves of constant values of \( f(x,y) \), different colors or grayscale are shown to indicate the variation in the function \( f(x,y) \). Contour plots and density plots (as well as a number of other plots) can be obtained by using the option \textit{Plots > Plot Builder} in a context menu associated with the expression \( f(x,y) \).

As an example, consider the expression,

\[ x \sin(x) + y \cos(y) \]

Type this expression in a \textit{Math} input format, select the expression by clicking on it, and do a \textit{right-click} to produce the corresponding context menu. Then, select the option \textit{Plots > Plot Builder}. As a result you will get the dialog box shown below.

\[ \text{Figure 41} \] – Two-dimensional plot with \( y \) logarithmic scale (semilogarithmic plot in \( y \)).
Figure 42 – Dialog box for the Plots > Plot Builder option on the context menu for an expression of the form \( f(x,y) \).

This dialog box allows us to select from a variety of plots, as shown in Figure 42. I have selected the option 2-D contour plot in the Select Plot box. This selection shows two parameters at play, \( x \) and \( y \). The dialog box also indicates the default ranges of those parameters, -5 to 5, for both of them. Keeping those default ranges, press [Plot] to produce the contour plot. The resulting contour plot is shown in Figure 43.

Click on the plot and open the corresponding context menu to see the options available. The contour plot being a two-dimensional plot will show a context menu like that of the 2-D plot of Figure 26.

Exercise
To produce a density plot, click on the expression of interest, and open the corresponding context menu (right-click), then select Plots>Plot Builder, but this time select 2-D density plot in the Select Plot box. Modify the scales for the two parameters if you so desire, and press [Plot] to produce the density plot equivalent to the contour plot of Figure 43.
Animation of a surface using context menus
Consider the expression
\[ \sin(a \cdot x) + \cos(a \cdot y). \]

Enter this expression in as a Math input in a Maple worksheet. Click on the expression, and generate the corresponding context menu (right-click). Then, select the options Plots > Plot Builder. In the resulting dialog box, select Animation in the Select Plot Type box. Keep all the default selections as shown in the dialog box, except for the range of the animation parameter \( a \) which should be changed to the range 0 to 2. Then press [Plot].

Click on the resulting plot to open the animation toolbar (see Figure 32), and press the Play button in the toolbar (item 3 in Figure 32) to see the animation of the surface produced.
Animation of a contour plot using context menus

Consider once more the expression

\[ \sin(ax) + \cos(ay). \]

Enter this expression in as a *Math* input in a Maple worksheet. Click on the expression, and generate the corresponding context menu (*right-click*). Then, select the options *Plots > Plot Builder*. In the resulting dialog box, select *Animation* in the *Select Plot Type* box, and select *2-D Contour plot* in the *Select Plot* box. Make sure that \( x \), \( y \), and \( a \) are selected as the *First*, *Second*, and *Animation* parameters in the dialog box, with ranges of -5 to 5 for both \( x \) and \( y \), and of 0 to 2 for \( a \). Press [Plot].

Click on the resulting plot to open the animation toolbar (see Figure 32), and press the *Play* button in the toolbar (item 3 in Figure 32) to see the animation of the contour plot produced.

Animation of a density plot using context menus

Repeat the exercise from the previous section, but selecting *2-D Density Plot* in the *Select Plot* box in the *Plot Builder* dialog box. Make sure that the parameters and ranges are the same as in the contour curve animation exercise, and press [Plot]. Run the animation from the animation toolbar after clicking on the plot.

Example of a well-documented worksheet

Maple includes some examples of well-documented worksheets that address specific problems in electrical engineering. Let's look to one of them (the *Harmonic Oscillator* worksheet) as an example of the type of worksheets you want to develop for the solution of your own assignments.

To access the *Harmonic Oscillator* worksheet, select the option *Help > Take a Tour of Maple*. This will open the tour worksheet. On the right-hand side of this worksheet there is a column labeled *Sample Documents*. The *Harmonic Oscillator* worksheet can be opened by clicking on the first link in the *Sample Documents* column. Open the worksheet and explore it using the scroll bar on the right-hand side of the document. (Alternatively, use *Help > Manuals, Dictionary, and more... > Applications and Examples*. This will open the *Applications and Examples* worksheet. The *Harmonic Oscillator* worksheet can be accessed by clicking in the proper link under the section *Applications*).

The *Harmonic Oscillator* worksheet contains a title, a figure (which was produced in a sketching software and pasted into the worksheet), two sections (*Initialization, System Analysis*), and tables with text, equations, and graphics.

Use the options *View > Collapse All Sections* to “close down” the sections in the worksheet. Then, use *View > Expand All Sections* to “open them up.” If you have collapsed all sections at once (*View > Collapse All Sections*), you can open one at a time by clicking on the arrow attached to the section title. You can also selectively close one section at a time by clicking on the vertically-downward arrow next to the title of an open
section or sub-section. Try these options with this worksheet. Before continuing, make sure that the two sections are open (i.e., use View>Expand All Sections), and scroll the worksheet to the top.

To activate the worksheet select Edit > Execute > Worksheet. This will run all the executable commands in the worksheet. You will see the worksheet scrolling down as the commands are executed. Scroll the worksheet up and down and stop at one of the graphs. Notice that the graphs have sliders attached to them, which are associated with parameters used in the equations. By clicking on the slider and moving the slider indicator you can change the values of the parameters and modify the plot. Try some changes in the parameters by using the sliders. Click the Harmonic Oscillator worksheet when done.

Maplets
The ability of adding sliders and other components facilitate sensitivity analysis in a graphical format. Such interactive displays are referred to as Maplets. Note: A self-standing application with a GUI (Graphics User Interface) programmed in Java is referred to as an applet, from app – an abbreviation for application – and let indicating something small or brief. The word Maplet is a play on Maple and applets.

Maplets can be built by adding GUI components to an area of a Maple worksheet. To see the available components click on the Components palette in the Maple 10's palette collection (see Figure 11).

The building of Maplets is an advanced application in Maple, therefore, it will not be covered in this document. However, information on Maplets is available in the Help facility. For example, try Help>Manuals, Dictionary, and more...>Manuals>User Manual to open the User Manual worksheet. Click on item 9 Maplets to learn the basics of Maplets.

Typically, you'll need some programming to activate a Maplet. Maple programming has not yet covered, another reason to postpone working with Maplets for the time being.

Worksheet mode
By default (e.g., when using Cntl+n), Maple worksheets follow a Document mode. Thus, so far we have used File>New>Document mode to generate new Maple worksheets. In this exercise we'll open a new Maple worksheet in Worksheet mode by using File> New> Worksheet mode. This will generate a new worksheet showing what is called a execution group prompt at the upper left corner of the worksheet. Such a prompt is shown in the following figure.

Figure 44 – Execution group prompt available in Worksheet mode.

Getting Started with Maple 10 – Page 50
When you type in front of the execution group prompt, the input shows up, by default, in *Math* input format. For example, at the prompt, type:

$$int(x^2, x = 0..2)$$

and press return. This command calculates the definite integral of $x^2$ within the limits 0 and 2. The result, given in symbolic format, is $\frac{8}{3}$. This result is shown within the execution group where the command was entered. Also, after executing this command, Maple automatically generated a new execution group immediately below, and moved the cursor at the prompt of that new execution group.

We could use the *Expression* palette to enter the same integration in formal mathematical mode by clicking on the definite integral button in the palette. We need to keep the cursor in front of the new execution group prompt. The resulting operations are shown below:

<table>
<thead>
<tr>
<th>Maple Input format</th>
</tr>
</thead>
<tbody>
<tr>
<td>$\int_0^2 x^2 , dx$</td>
</tr>
<tr>
<td>$\frac{8}{3}$</td>
</tr>
</tbody>
</table>

**Maple Input format**

A new execution group prompt will now be available. Keeping the cursor in front of the prompt of this new execution group, we are going to change the input mode by pressing [F5]. In *Document mode* (i.e., in all the examples in the previous sections of this document), pressing [F5] changed the input mode from *Math* to *text*. In Worksheet mode, however, pressing [F5] changes the input mode from *Math* to *Text/Maple Input*. This is the preferred input mode in earlier versions of Maple (e.g., before version 8), and it's still available in Maple 10 for those of us (like me) who learned Maple way before version 10 became available.

$$int(x^2, x=0..2);$$

As an exercise, we'll enter now `int(x^2,x=0..2);` and press [Enter]. The resulting execution group is shown below.

Note: in *Maple Input* mode you need to end Maple commands with a semi-colon (;) or a colon (:). When you end a command with a colon, the command is executed, but no output is shown, e.g.,
In Maple 10, if you are using Maple Input to enter commands, and you forget to end it with a semi-colon (or colon), Maple will complete the command anyway, but issue a warning that an incomplete command was entered. Here's an example:

\[
> \int(x^2, x=0..2):
\]

To correct this oversight one needs only click back on the offending command, type the semi-colon (or colon), and press [Enter] again. Maple will recalculate the command and remove the warning message.

**Inserting execution groups**

An execution group can be inserted below the current location of the cursor by using Cntl+j, or above the current location of the cursor by using Cntl+k. Alternatively, you just can use the options Insert>Execution Group>Before Cursor or Insert >Execution Group > After Cursor. Another possibility is to click the Inset Maple Input button (item 12 in Figure 10) available in the toolbar.

As an exercise, click on any of the execution groups currently available in your worksheet and insert execution groups before and after.

**Deleting execution groups**

To delete an execution group, click in front of the prompt, and use Cntl+Delete. You can also use Cntl+Delete to delete individual objects such as Maple input and output, and graphs. All you need to do, is highlight the object you want to delete before using Cntl+Delete. Try some execution group deleting in your worksheet.

**Inserting a text prompt in an execution group**

Text could be used to document the operation(s) in an execution group. Use Cntl+Shift+j to insert a text prompt before the current cursor location, or Cntl+Shift+k to insert a text prompt after the current cursor location. Alternatively, you just can use the options Insert>Paragraph>Before Cursor or Insert >Paragraph > After Cursor. Another possibility is to click the Insert Text button (item 11 in Figure 10) available in the toolbar. This latter option will actually insert a new text block separate from any execution group. Try the different commands listed in this paragraph to insert text in your execution groups, or to insert a separate text block.
Inserting and removing sections
Use Insert>Section to insert a section (or Insert>Subsection) immediately below the current cursor location. If you want to insert a section (or sub-section) encompassing a number of execution groups, first highlight the collection of execution groups you want to collect into a section, and then press the Insert Section button (button 13 in Figure 10) in the toolbar. This will indent the selected execution groups into a section or sub-section. To remove them from a section or subsection, use the Remove Section button (button 14 in Figure 10).

Multiple-lines in a single execution group
To enter more than one command into a single execution group, type Shift-Return after each line. For example, type:

\[
\begin{align*}
\text{[ F5 ]} & \quad (x+y)^2; \quad \text{Shift-Return} \\
& \quad (x-y)^2; \quad \text{Shift-Return} \\
& \quad + + \% \% \% \ \text{Return}
\end{align*}
\]

to produce the following results:

\[
\begin{align*}
\texttt{\textgreater } & \quad (x+y)^2; \\
& \quad (x-y)^2; \\
& \quad + + \% \% \; \\
& \quad (x+y)^2 \\
& \quad (x-y)^2 \\
& \quad (x-y)^2 + (x+y)^2
\end{align*}
\]

Using palette commands in Maple Input format
If we have selected the Maple Input format in an execution group, inserting expressions from the Expression palette will produce the original Maple command corresponding to the desired expression. Table 2, in the following page, shows a listing of some of the calculus commands from the Expression palette and their equivalent Maple Input commands. Table 3, on the other hand, shows a similar listing for a number of algebraic operations. The operation \( a^b \) is straightforward, i.e., \( a^{b} \). So it's the case with the trigonometric functions, i.e., \( \sin(a), \cos(a), \tan(a) \). Table 4 shows operations related to the definition of functions. These operations are also available at the Expression palette.

Table 4 shows palette expressions from the Expression palette and their equivalent Maple Input commands for function evaluation and definitions. The six items shown are the following:

1. Evaluation of univariate functions
2. Evaluation of bivariate functions
3. Definition of univariate functions using the standard “mapping” notation
4. Definition of bivariate functions using the standard “mapping” notation
5. Definition of multi-value or piecewise functions

Getting Started with Maple 10 – Page 53
Table 2 – Palette expressions and Maple Input commands for calculus operations

<table>
<thead>
<tr>
<th>Palette expression</th>
<th>Corresponding Maple command</th>
</tr>
</thead>
<tbody>
<tr>
<td>( \int f , dx )</td>
<td>[&gt; \text{int}(f, x); ]</td>
</tr>
<tr>
<td>( \int_a^b f , dx )</td>
<td>[&gt; \text{int}(f, x=a..b); ]</td>
</tr>
<tr>
<td>( \sum_{i=k}^n f )</td>
<td>[&gt; \text{sum}(f, i=k..n); ]</td>
</tr>
<tr>
<td>( \prod_{i=k}^n f )</td>
<td>[&gt; \text{product}(f, i=k..n); ]</td>
</tr>
<tr>
<td>( \frac{d}{dx} f ) or ( \frac{\partial}{\partial x} f )</td>
<td>[&gt; \text{diff}(f, x); ]</td>
</tr>
<tr>
<td>( \lim_{x \to a} f )</td>
<td>[&gt; \text{limit}(f, x=a); ]</td>
</tr>
</tbody>
</table>

Table 3 - Palette expressions and Maple Input commands for algebraic operations

<table>
<thead>
<tr>
<th>Palette expression</th>
<th>Maple Input command</th>
</tr>
</thead>
<tbody>
<tr>
<td>( a_n )</td>
<td>[&gt; a[n]; ]</td>
</tr>
<tr>
<td>( \sqrt{a} )</td>
<td>[&gt; \sqrt{a}; ]</td>
</tr>
<tr>
<td>( \sqrt[n]{a} )</td>
<td>[&gt; (a)^(1/n); ]</td>
</tr>
<tr>
<td>( a! )</td>
<td>[&gt; a! ; ]</td>
</tr>
<tr>
<td>(</td>
<td>a</td>
</tr>
<tr>
<td>( e^a )</td>
<td>[&gt; \exp(a); ]</td>
</tr>
<tr>
<td>( \ln(a) )</td>
<td>[&gt; \ln(a); ]</td>
</tr>
<tr>
<td>( \log_{10}(a) )</td>
<td>[&gt; \log<a href="a">10</a>; ]</td>
</tr>
<tr>
<td>( \log_b(a) )</td>
<td>[&gt; \log<a href="a">b</a>; ]</td>
</tr>
<tr>
<td>( \binom{a}{b} )</td>
<td>[&gt; \text{binomial}(a,b); ]</td>
</tr>
</tbody>
</table>

Getting Started with Maple 10 – Page 54
Table 4 - Palette expressions and Maple Input commands for function definition and evaluation

<table>
<thead>
<tr>
<th>Palette expression</th>
<th>Maple Input command</th>
</tr>
</thead>
<tbody>
<tr>
<td>$f(a)$</td>
<td>$&gt; f(a);$</td>
</tr>
<tr>
<td>$f(a, b)$</td>
<td>$&gt; f(a, b);$</td>
</tr>
<tr>
<td>$f := x \rightarrow y$</td>
<td>$&gt; f := x \rightarrow y;$</td>
</tr>
<tr>
<td>$f := (x1, x2) \rightarrow y$</td>
<td>$&gt; f := (x1, x2) \rightarrow y;$</td>
</tr>
<tr>
<td>$f(x)$ $</td>
<td>x = a$</td>
</tr>
<tr>
<td>$\begin{cases} -x, &amp; x &lt; 0 \ x, &amp; x &gt; 0 \end{cases}$</td>
<td>$&gt; \text{piecewise}(x&lt;0, -x, x&gt;0, x);$</td>
</tr>
</tbody>
</table>

Table 5 shows some examples of Greek characters from the Greek palette in Maple 10, and the equivalent reference in Maple Input form.

Table 5 – Greek letters and their references in Maple Input form

<table>
<thead>
<tr>
<th>Greek character from palette</th>
<th>Maple Input reference</th>
</tr>
</thead>
<tbody>
<tr>
<td>Γ</td>
<td>$&gt; \text{GAMMA}$</td>
</tr>
<tr>
<td>Θ</td>
<td>$&gt; \text{ Theta}$</td>
</tr>
<tr>
<td>φ</td>
<td>$&gt; \text{Phi}$</td>
</tr>
<tr>
<td>γ</td>
<td>$&gt; \text{ gamma}$</td>
</tr>
<tr>
<td>θ</td>
<td>$&gt; \text{ theta}$</td>
</tr>
<tr>
<td>ϕ</td>
<td>$&gt; \text{ phi}$</td>
</tr>
</tbody>
</table>

Notice that the letter Γ (upper-case gamma) is referred to as GAMMA in Maple Input format. The name GAMMA actually refers to the gamma function from mathematics (see the mathematical dictionary, Help>Manuals, Dictionary, and more>Dictionary). Upper-case Greek letters have names that start with upper-case letters in Maple Input format. Lower-case Greek letters' names start with lower-case letters in Maple Input format. See Table 1 for the list of names of the letters in the Greek alphabet.
As an example of application of the *Maple Input* commands and characters of Tables 2 through 4, consider the following Maple command and its result:

\[
\text{\texttt{\textgreater \ int((alpha+beta)^2*xi+tau,xi=0..alpha/2);}}
\]

\[
\frac{1}{8} (\alpha + \beta)^2 \alpha^2 + \frac{1}{2} \tau \alpha
\]

One disadvantage of using *Maple Input* format is that the mathematical expression thus typed is not shown in full mathematical format before it is calculated. One possible solution, if using this type of input, is to enclose the expression in quotes, and add a \% symbol (referred to as the *ditto* operator) to the command line, e.g.,

\[
\text{\texttt{\textgreater \ 'int((alpha+beta)^2*xi+tau,xi=0..alpha/2)'\%;}}
\]

\[
\frac{1}{8} (\alpha + \beta)^2 \alpha^2 + \frac{1}{2} \tau \alpha
\]

**The ditto (%) operator**

The *ditto* operator, represented by the percentage symbol, is a reference to the most recent result in Maple. Two ditto operators represent the second-to-most-recent result, and so on. As shown above, the ditto operator is very useful when using *Maple Input* notation, but has not much use in the *Document* mode of Maple 10's worksheets. The ditto and double-ditto operators were used in an earlier example (see equation (6) in page 53).

**Additional characters in *Maple Input* representation**

The *Common Symbols* palette includes some characters of interest for which we present its *Maple Input* representation in Table 6.

**Table 6** - Additional characters and their references in *Maple Input* form

<table>
<thead>
<tr>
<th>Palette characters</th>
<th>Maple Input reference</th>
</tr>
</thead>
<tbody>
<tr>
<td>( \pi )</td>
<td>\texttt{\textgreater \ pi}</td>
</tr>
<tr>
<td>( e )</td>
<td>\texttt{\textgreater \ exp(1)}</td>
</tr>
<tr>
<td>( i, j, \text{or} I )</td>
<td>\texttt{\textgreater \ I}</td>
</tr>
<tr>
<td>( \infty )</td>
<td>\texttt{\textgreater \ infinity}</td>
</tr>
</tbody>
</table>

*Getting Started with Maple 10 – Page 56*
Examples using these characters in *Maple Input* format are shown below.

```maple
> 'sum(1/(Pi*k)^2, k=1..infinity)' ;%
\[
\sum_{k=1}^{\infty} \frac{1}{n^2 k^2}
\]
\[
\frac{1}{6}
\]  
(1)

> (alpha+I*beta)*(alpha-2*I*beta):evalf(expand(%%));
\[
(a + i \beta) (a - 2 i \beta)
\]
\[
a^2 - 1. I a \beta + 2. \beta^2
\]  
(2)
```

**Summary**

In summary, we can create worksheets in *Document* mode or in *Worksheet* mode. *Document mode*, which is the new preferred mode for Maple 10, allows for free location of entry points and allows to enter commands in *Math* input format. The [F5] key in *Document* mode toggles input from *Math* input form to *Text*.

On the other hand, in *Worksheet* mode, we use *execution groups* which can take commands in *Math* input form or in *Maple Input* form. Use [F5] to toggle between these two input forms in an execution group. *Maple Input* form is the old-fashioned (but still useful, particularly for programming) way to enter Maple commands.

So, which mode is better? The *Document* mode is definitely the best and it is today's preferred mode for Maple worksheets. There is, however, an enormous quantity of old-fashioned Maple worksheets that have been developed in the last 10+ years, for that we can use the *Maple 10 Classical Worksheet application* to operate upon those worksheets. This approach is presented in the next section.

**The Maple 10 Classical Worksheet application**

This application can be used to read old-fashioned worksheets created in earlier versions of Maple. For an individual Maple 10 server, you will find the Classic Worksheet Maple 10 icon at *Start>All Programs>Maple 10> Classic Worksheet Maple 10*. Use it to open old-fashioned Maple worksheets created with previous versions of the software. You can find many of those worksheets in my web site:

[http://www.engineering.usu.edu/cee/faculty/gurro/](http://www.engineering.usu.edu/cee/faculty/gurro/)

Find the *Software* and then the *Maple* links.

The following is a picture of a classic worksheet opened and operated upon in *Classic Worksheet Maple 10*.
The preferred Maple 10 interface (shown in the previous 50+ pages) does not support many elements that were used in the classic worksheets. Thus, care must be exercised if opening an old-fashioned worksheet in Maple 10. If in doubt, use the Classic Worksheet Maple 10 application, and try to copy and paste components from the old-fashioned worksheets into new versions using the new Maple 10 interface.