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   This document is an introduction for Math 2270 students who may not have done previous work 
with MAPLE or in the Math lab, or who may just want to brush up on their skills.  An on-line 
version of this tutorial, without Maple output, is at  
http://www.math.utah.edu/~korevaar/2270fall05/2270tut.mws

The Math 2270 projects can be done in versions five and above of Maple, with minor changes.  The 
Math Lab, EMCB, and Marriott Library all have version 8 of Maple.  A student version of Maple 9, for 
home computers is available from the bookstore for $129.95.  If you do work in Maple 9 but will want to 
work on the same file later using an earlier Maple version, make sure to save your file with this option.

1)  Using the Math Computer Lab:
The Math Department has a walk-in computer lab in the Math Student Center, located underneath the 
plaza connecting JWB to LCB.  There is also a computer classroom in LCB 115. Useful information 
about most aspects of the lab can be found by following links from the Math Department web pages, e.g. 
starting at   http://www.math.utah.edu/ugrad , or http://www.math.utah.edu/ugrad/mathcenter.html . You 
can find out about lab hours, X-windows, Maple, Unix commands,  browsers, file editing, mail, etc.  
     You can access Math Department Maple (in its own window as opposed to the cumbersome line 
command form) remotely from a linux/unix system, from a mac running OSX (download the free X11 
xwindows from Apple or from your installation disks), or from a PC running windows if you have ssh 
client capabilities and xwindows capabilities.  Apparently there is a free package for PC’s called cygwin 
which you can download to enable this.  You do not want to try remote access of Maple with only a 
modem connection, it will be unbearably slow.

1a) Logging on:
Almost all students who are registered in Math 2270, or in any other math class,  will already have 
accounts set up in our lab.  Since these accounts are created from University class lists,  late-registering 
students may not be included. Your login information is NOT based on your UNID, see below.  If you’re 
not on our master list, a lab assistant can help you apply for an account - provided you have brought your 
student I.D. to show that you are a University student.

The lab machines are left on - move the mouse or hit a key to wake yours up.  There should be a box 
asking for your login name, and then for you password.

Your login name will be of the form c-azbc, where ‘a’,‘b’,‘c’ are your last, first, and middle initial, 
respectively and ‘z’ is the last letter in your last name.  For example, if your name is Ulysses Attila 
Eratosthenes, your login name will be c-esua.  (Many people have the same initials, so to ensure your 
login name is unique, a digit may be added after the initials, eg.  c-esua1, c-esua2, ...).  For people with 
more complex (eg.  hyphenated names) only the first character of each name is used.



Passwords  Your initial password will be the letters as in the login name, followed by the last four digits 
of your University ID number (e.g., if your UID is 123456789 and your login name is c-esua, then your 
password is esua6789) or if the login name is c-esua2 the password is still esua6789).




Once you’re logged in, the default environment of our unix-based system is called the common desktop 
environment, and you will see a maple leaf icon for MAPLE, as well as a MOZILLA browser icon.  You 
can open these programs by clicking on the icons.

1b)  Changing password: Upon first logging in you should change your password.  To do so, log in, 
open an xterm window, then type ‘‘passwd’’ (followed by RETURN).  If there is a problem here try 
typing ‘‘passwd’’ followed by your username (eg. ‘‘passwd c-esua’’). Next type your old password (the 
one you used to login), and then type your new desired password twice as instructed.  Your new 
password is effective within 30 minutes.  If you forget your password, request a new one (from the Lab 
Assistant in the Math Center).  Your password must consist of at least 6 characters (upper and lower case 
letters, and digits).  You should take care to choose one that is very difficult to guess, and keep it to 
yourself!

1c)  Logging out: In CDE there is a logout or exit icon at the bottom of your desktop.  You might also 
be able to find it on your right mouse button, after putting your mouse cursor in a background field.
     

2)  Opening browser, maple, mail, more:    
For your Math 2270 purposes you need to be able to open your browser (to download files) and Maple 
(to work on them).  Open  Mozilla and Maple now: in CDE use the icons at the bottom of the desktop. 
You have a mail utility for your math account down there as well, with icon looking like some 
envelopes.
    
3) Maple:   
If you are starting the tutorial at this point (because you’re doing it on your own at another location or 
already knew the Math Lab system), you should have opened a  maple window, probably version 8 
(versions 5,6,7, 9 should also work), as well as a web browser.

Maple is partly just a very fancy calculator; it can do practically any undergraduate mathematics 
computation or symbolic manipulation.  You can write programs in Maple and draw pictures as well. 
But you can also use it to create documents which mix text with computations, and you can export 
Maple output to other software to create interesting documents.

If you are doing a homework assignment you can intersperse text with computations using the toolbar:  
to get a computation prompt click on the ‘‘[>’’ box near the top.  To insert text click on the ‘‘T’’ box.  
Or you can change command fields (starting with "[>") into text fields by putting the cursor into them 
and then choosing "T".  You can use the mouse to cut, paste, and edit a document.  You can change 
fonts, formats, and use other standard text editing tools by choosing appropriate menu items.  This 
document you are reading is a Maple document even though it is largely text.  You will learn by doing - 
and by asking your neighbor or the lab assistant.

New User’s Tour, other introductions, opening files from the web:
Under the Help button at the top right of your Maple window you will find the choice "New User’s 
Tour".  This is a good way to learn generally about what Maple can do.  After making this menu choice 
Maple may hide the beginning of the tour behind other active windows;   use the "Window" menu item 
to bring the tour window to the front.   If you wish you can explore now, or you can continue with the 
Math 2250 notes below and come back to the tour later.  To close the new tour (or any other top 
window), use the ‘‘close’’ option inside the ‘‘file’’ menu item.  To keep the tour open but bring another 



window to the front, use ‘‘window’’ menu item.

Another good introduction to Maple is located at http://www.math.utah.edu/~gardiner/Intro.mws.  (If 
your computer is appropriately configured clicking on this hyperlink will open your browser and go to 
the indicated URL.  You can then save the file to your computer, and then open it from Maple if this 
does not happen automatically.)  Alternately, if you have a browser open you can open Maple files 
directly off the internet by using clicking successively on  File -> Open URL, in the Maple menu items 
at the top of the Maple window.  You could try this for Angie Gardiner’s introduction, or this one 
located at
http://www.math.utah.edu/~korevaar/2270fall05/2270tut.mws

Entering Maple commands: 
To give you a brief taste of what Maple can do, we will try a few commands.  Move your cursor into the 
"Untitled" (new) Maple window which you created in step (2).  Commands begin on  lines having  a 
command prompt ‘‘>’’, and should be ended with either a semicolon ; or a colon :  If you end with a 
semicolon you will see visible output, if you end with a colon the output will be suppressed even though 
the command is executed.  Maple will not execute a command until you type the ‘‘return’’ or ‘‘enter’’ 
key.  If you have a multiline command use ‘‘shift-return’’ to change lines without executing. 

If you incorrectly align parentheses or brackets, or do something else which makes your command 
unexecutable you will get a ‘‘syntax error’’ message and Maple will try to point out your mistake with 
the cursor and cryptic diagnostic phrases.  After a while you will become good at fixing these mistakes 
but they can be annoying at first.  Spaces are ignored in Maple, so you may use them to make input 
easier to read.  You can enter explanatory comments in a command line by inserting a ‘‘#’’ to the left of 
the comments; Maple ignores any text after the #.  Sometimes this is more informative then entering 
nearby explanatory text, especially if you are explaining various steps in a subroutine.

 Now, let’s try some commands. (You try just the math commands, the editorial comments were only 
added to explain what the particular commands are illustrating ! )  Check that you understand what each 
command is doing.

> 3+4; 4+5: 6 * 7;     #one of these computations will not be shown

          #even though all three will be done, illustrating the 

          #difference between a semicolon and a colon

                 

> (3+4)7;       #if you want to multiply you must use *, so after

          #trying the command as given, insert a * to fix the

          #resulting syntax error.  You can execute a line or

          #execution group (bracketed on the left) if

          #your cursor is anywhere in it. You can move the

          #cursor with the mouse or the arrow keys. Maple will

          #try to put it in a good place if it detects an error.

Error, unexpected number


> (3+4)^2/7; 3+4^2/7; evalf(3+4^2/7);  #the evalf  command gives a 

          #decimal approximation instead of an algebraic 

          #expression. Notice that if given a choice, Maple 

          #computes powers first, then multiplies and divides, 

          #and finally adds or subtracts.



Maple can do computations for almost any Math you can think of....see the new user’s tour.  Or you can 
have a look at the varied commands in the file
http://www.math.utah.edu/~korevaar/ACCESS2005/MapleExpls.mws

Here are some linear algebra examples:
> with(linalg):  #loads linear algebra package...there is

    #also a newer computational package called LinearAlgebra

> A:=matrix(2,2,[1,2,3,4]);  #define a matrix

B:=matrix(2,2,[-1,0,2,1]);

v:=vector([1,2]);          #define a vector  

 := A








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3 4

 := B








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-1 0

2 1

 := v [ ],1 2
> inverse(A);  #matrix inverse

evalm(A&*B); #evalm means evaluate matrix; "&*" stands

    #for multiplication of matrices


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> rref(augment(A,v));  #three ways to solve Ax=v

evalm(A^(-1)&*v);

linsolve(A,v);


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Making new files which mix text, commands and output:
From the "File" menu item, create a new worksheet.(It will start out being called Untitled(2) or 
something like that.  The first time you save it you can pick any name you want, as long as it ends in 
.mws, for Maple worksheet. In your new worksheet turn the command field into a text field by putting 
your cursor into it, and then using the‘‘T’’ menu item. Type in the title ‘‘My first Maple worksheet’’ 
(center it with the menu option on the right side of the toolbar), as well as your name and today’s date. 



When you are doing your Maple projects you will be expected to hand in more than a page of 
computations: You will be expected to add text explanations of what you’ve been doing.  In general, if 
you move your cursor to a command field and the press the [> button with your mouse, Maple makes a 
new command field directly below it.  If you move to the new command field and press the T button you 
will have a text field into which you may write, using the rudimentary word processing tools on the 
Maple menu bar.  In text fields you may eliminate the brackets along the left margin by highlighting 
them and deleting.

Saving Files:
It is always a good idea to save your maple file periodically.  Save all of your documents - this one, 
which I called 2270tut.mws (you can change the name if you want), as well as your untitled documents. 
Use the tool bar, using the "save" option under the "File" menu item. The first time you save a new file, 
and any time you use the "save as" option, you will be asked to name your file and say where you want 
to keep it.  You name it in the left part of the box, being careful to keep the suffix ".mws" so that Maple 
knows this file is a Maple Work Sheet.  If your directory is new you probably haven’t made any 
subdirectories yet (unix command mkdir, in a local window), but as you create more files you may wish 
to organize where you save them using the tree structure of  Unix directories, which you can follow in 
the right side of your saving box.  You use various UNIX commands in your local or terminal window to 
organize your directories.  For more information about this,  go to the directory
http://www.math.utah.edu/computing/

It will probably happen some time that you will crash Maple long after your last save.  This will not 
make you feel happy but will teach you an important lesson.  
    
Printing:
In the menu bar click successively on  file->print->print command.  Then in the print command box 
choose the name of the printer you want to use.  In UNIX you also need the prefix lpr -P (spaces 
important), which stands for line printer - P.  For example, the printer in the math center room 115 is 
called mc155c, so you want to enter lpr -Pmc155 into the print command box, and then  click on the 
print box at the bottom of the window and your file should print. The print command in the room LCB 
115 would be lpr -P lcb115.  If you have trouble printing ask a lab assistant for help.  One glitch 
which seems to occur is that figures don’t print correctly.  If this happens try modifying the print 
command to lpr -l-Pmc155 or lpr -oraw-Pmc155.  You can also print postscript files to your math 
directory by using the "output to file" choice in the printing dialog box.

Execution Groups:
You can modify the text and input using the toolbar and menu options.  You will notice many brackets 
on the left of the document.  These are execution groups.  Maple will execute everything in one 
execution group at once, and then move the cursor to the next execution group.  You can create large 
execution groups by highlighting sections of a document, using Edit->Split or Join->Join Execution 
Groups.  You can remove brackets by highlighting them with the mouse and deleting them with the 
delete key or the menu option.  And you already learned how to insert new prompts or new text 
wherever your cursor is, by using the [> and T buttons on your toolbar.


